skip to Main Content

Old App Versions with Siri Shortcuts

When Siri Shortcuts came out I was extactic to get my hands on it and see what it can do, but I ran into a problem that I think needs to be addressed by Apple and the Siri Shortcuts team. The problem is that some applications that have since moved on to a new version are not working properly in Siri Shortcuts.

For example, I had a Ulysses Workflow that was imported into Siri Shortcuts after updating the app but when I opened it up I saw this:

I thought it was odd seeing this as I had the latest version of Ulysses installed on my device. After some troubleshooting and testing I have found a temporary solution.

For Ulysses, and possibly other apps, you need to install the older version of the application—in this case Ulysses Classic—and once you do that the error of the application not being installed will go away. In fact when you run the Shortcut it opens the new version of Ulysses, not the older version.

From there you have both the current version of Ulysses and Ulysses Classic installed, which is not ideal. I found that you can actually uninstall Ulysses Classic once you run a Shortcut with Ulysses in it. Once you have tested a shortcut after installing the older version, you can then uninstall the older version and see if adding actions for that application still works. For Ulysses it worked fine for me, but not so much for Tweetbot.

Tweetbot has gone through 4 version of the application and each new version has their own application, which was done to allow the developers over at Tapbots to continue to gain revenue as they add more and more features and support to their app. The problem with this when it comes to Siri Shortcuts is that for some reason the version it is trying to use is Tweetbot 3, not Tweetbot 4, the latest version of the application.

So, I did some testing and found out that installing Tweetbot 3 made the shortcut work and it indeed did open Tweetbot 4 instead of 3 when running the action. However, when I tried it uninstall version 3 the shortcuts I built and new ones I tried to build all came back with the error of the application not being installed.

In this case the solution isn’t a simple install and uninstall of the older version of the app. Instead you need to keep the older version of the application to allow the shortcut to work properly. My suggestion is just put it in the back of a folder on your home screen so it isn’t taking up precious real estate on your screen built still allows you to run shortcuts for Tweetbot.

Why I Think This is Happening

The reasoning for this error saying the application is not installed, I think, has to do with Siri Shortcuts requiring a specific app be installed, in this case older versions of the app when Workflow was in its heyday.

Now, as far as why it is opening the newer version of the apps when both are installed, I think, has to do with the newer version having the same x-callback-url and those newer version of the app taking priority whenever those urls are opened.

So, if you see this problem with certain apps and you know that you have the older versions in your purchase history try and install it and see if that fixes your problem.

As for a permanent fix, I think Apple is aware of this problem as they have seemed to be working with some of the developers on this and are making server-some changes to the application to prevent this issue going forward.

If you notice any apps doing this and want to spread the work let me know on Twitter or feel free to email me.

Leave a Reply

Your email address will not be published. Required fields are marked *

Back To Top